Vilkas Now shops outage

Incident Report for Vilkas

Resolved

All services are now fully operational. Thank you for your patience while we worked to restore normal operations.
Posted Sep 25, 2025 - 15:57 EEST

Update

Email services have now been restored. All Vilkas systems are operating normally, and we will continue to monitor to ensure stability.
Posted Sep 25, 2025 - 15:28 EEST

Update

We experienced a hardware failure (power supply) at our datacenter, which escalated into a wider service disruption. Most Vilkas systems have been back online since approximately 13:24 CET, but we are still seeing issues with email/SMTP servers. Our provider is continuing work on full recovery.
Posted Sep 25, 2025 - 15:21 EEST

Update

We are continuing to monitor for any further issues.
Posted Sep 25, 2025 - 15:19 EEST

Monitoring

The network issues at our datacenter have been resolved. Vilkas Now shops are operating normally, and we are monitoring the situation to ensure stability.
Posted Sep 25, 2025 - 14:52 EEST

Investigating

Our datacenter provider is currently experiencing network issues affecting Vilkas Now shops. Their team is actively working on a fix, and we will share updates as soon as more information is available.
Posted Sep 25, 2025 - 13:59 EEST
This incident affected: Vilkas Now Shops.